Tasks Availability

Incident Report for Progress Retail

Update

We are continuing to monitor for any further issues.
Posted Jul 11, 2025 - 14:28 CDT

Monitoring

As a result of the changes to workaround Microsoft's unplanned maintenance, we are seeing significantly improved stability. Some users may still encounter slower load times. We are continuing to investigate and work with Microsoft support engineers to resolve the issue permanently.
Posted Jul 11, 2025 - 08:56 CDT

Update

While performance has improved, there is still performance degradation across some aspects of tasks for some tenants. We are preparing a deployment with new infrastructure outside of the scope of the unplanned maintenance region to create permanent stability.
Posted Jul 11, 2025 - 07:34 CDT

Update

From Microsoft: "Currently, it seems that the maintenance is affecting the function instances when responding to client requests (slowness), but the responses are successful. We are still verifying."
Posted Jul 10, 2025 - 13:09 CDT

Update

We are continuing to work with Microsoft to escalate the issue. Service has been restored, but is still degraded.
Posted Jul 10, 2025 - 12:29 CDT

Identified

Microsoft has informed us of maintenance to our Azure App Service instance(s) in the Central US region. Due to a critical hotfix or urgent update, Microsoft/App Service was not able to provide an advanced notification. We are re-deploying the Tasks microservice to attempt to resolve the issue.
Posted Jul 10, 2025 - 10:44 CDT

Investigating

We are currently investigating the issue.
Posted Jul 10, 2025 - 10:03 CDT
This incident affects: Task Management & Execution (Task Management Calendar, Task Management List View, Task Management Location View, My Tasks, Scheduled Tasks).